Do I need to update the Branch SDK for iOS 14?

You will need to update your app to support Apple's SKAdNetwork. If you want to use the Branch SDK to automatically invoke the relevant methods (recommended), you will need to ensure you're using SDK v.0.35.0+. If you are integrating these methods yourself, or using another SDK to do so, no Branch SDK update is required.

Branch iOS SDK versions 1.39.2+ additionally capture ATT opt-in/opt-out events when users interact with the new AppTrackingTransparency prompt. This update is optional, but provides additional data to help you understand your user flows.

Note for Cocoapods users: if you have platform :ios, '8.0' in your podfile, you will need to update this to '9.0' to get the latest Branch SDK.

Updated about a month ago


Additional Resources

iOS 14 FAQs

Do I need to update the Branch SDK for iOS 14?


Suggested Edits are limited on API Reference Pages

You can only suggest edits to Markdown body content, but not to the API spec.